Tekst


Formler
Tekst

Funktioner og formler til tekst

Tekstformler er ret nemme. Start med dem, hvis du er begynder. Det betaler sig stadig at øve sig. Download filen herunder - så kan du begynde at øve dig om et par minutter. 

xlEasy Formler Tekst 902: Find alle tekstfunktioner samt eksempler på formler du selv kan prøve.

Tekst

Der er 22 tekstfunktioner. De er ret nemme at forstå for de fleste. De kan kombineres i interessante formler. Et eksempel: Du har en liste med navne. Hele navnet (fornavn efternavn) står i samme celle. Du vil gerne have for- og efternavn i hver sin celle. Navnet står i celle B24, og fornavnet skal stå i C24.

Find den lille tekst " " i den store tekst "fornavn efternavn". Mellemrum skrives " ", og den store tekst står i celle B24. Derfor skrives formlen
=SØG(" ";B24;1)
Det side tal (1) betyder, at søgningen skal starte ved første tegn, dvs. fra starten. Resultatet af funktionen er et tal. I dette eksempel bliver det 8, idet mellemrummet er det 8. tegn i den store tekst. Vi ved også, fornavnet er de første 7 tegn. Derfor kunne vi skrive
=VENSTRE("fornavn efternavn";7) eller =VENSTRE(B24;7), hvilket vil give resultatet "fornavn". Men hvis nu fornavnet er Jens, dur det ikke. Vi laver nu en formel, der kan bruges til alle navne:
=VENSTRE(B24;SØG(" ";B24;1))
Find selv formlen til at udtrække efternavnet.

Andre tekstformler kunne være: Skriv et tal som en brøk. Hvis tallet er 3,25 kan du få vist det som 3 1/4 med formlen

=TEKST(B39;"#.##0 ?/4")

Se flere eksempler i xlEasy Formler.

 

Gå til toppen