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Introduction
xlEasy Project Plan and ProjectTools are used to plan, execute and terminate
projects. The focus is in planning and communicating.

News in version 606
•

New: Insert/Delete tasks, subproject and projects with shortcuts Ctrl+Plus and
Ctrl+Minus.

•
•

New: Automatic installation/upgrade when a new ProjectTools is opened.
New: Advanced filtering in Views. Select projects/subprojects based on name
pattern: Select all subprojects named "*development*".

•
•
•
•
•

New: Configure text on Gantt lines.
New: Progress can show effort (used resourced compared to budget)
UPD: Baseline function.
UPD: Absence (Production plan) handling is now more flexible.
UPD: Timeline color dependent on responsible is now standard.

News in version 510
•

New: Schedule a subproject from delivery date (ALAP = As Late As Possible or Late
Start). Input just end date and have all tasks scheduled from that.

•
•

New: New advanced features when filtering views. Fast, lightweight and code-based.
New: e-conomic integration is re-written to overcome limitations in datasets. Tested
with 25.000+ records.

•

New: In Consolidation an extra header can be inserted before each subset, making is
easier to navigate in large consolidated plans.

•

Fixed: Input end date and keep duration. Text on Gantt lines.

See also chapter History.
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Create a new Project plan

2.1 New Excel-file
You have received a project template in one of these formats: *.xlsb, *.xlsm or *.xltm.
xlsb and xlsm are normal Excel files with macros. You can use both. xltm is an Excel
(xltm) template (xltm) with macros (xltm).
During setup, you have chosen how to create a new Project plan: By using Files > New or
by copying.

Files > New
In Excel 2010, your templates are found under My templates.
In Excel 2013, look in Personal (or Custom).

Copy project plan
If you are using this method, your original is most likely an xlsb-file. Be sure to keep a
copy in a safe place.
A new project plan is created by copying in Windows Explorer or by open and save as in
Excel.

2.2 Add projects, sub projects and tasks
You can add new sub projects and tasks manually or through the menu in ProjectTools.

Add projects, subprojects and tasks
Add from keyboard (recommended!)
Shortcut Ctrl+Plus: Add a task. The task iis added below selected row. Insert
multiple tasks example: Selecting 3 rows before Ctrl+Plus will insert 3 tasks.
Ctrl+Plus in colimn ID: If a cell in column ID is selected you will get the dialogue
"Add…" where you can add projects, subprojects and tasks.
Shortcut Ctrl+Minus: Delete a task, a subproject or a project.

Note: Ctrl+Plus and Ctrl+Minus are standard Excel shortcuts. Outside the projectplan they
will work as usual.
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Add with dialogue
1

Select a cell in a sub project or a task.
New items are added after the active
row.

2

Go to group Project > menu Project >
item Add…
A dialog opens.

3

Select an option and click Add.

OBS: When a Project is added, a subproject and a task is also added. When adding a new
subproject, a task is also added.

Copy projects, subprojects or tasks
Copy a project with subprojects and tasks
1

Select id for a project. Select menu
Project > Copy.
You get this dialog: Choose Yes to
copy all project-rows.

2

The project with subprojects and tasks are copied. When ready you must
input new id. You can accept the next project number:
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Accept default, write your own number or get a total renumbering by typing
* (asterix).
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2.3 Edit project plan
Edit tasks
Your project template is ready with the necessary rows and columns, so you can start
typing tasks.
Input
You can overwrite and edit content in all cells. Be prepared: Some columns have
formulas. These columns have most often a colored background. If a formula disappears,
you just copy from another cell.
Move a task (up/down)
It is easy to move a task in the project structure. Use Ctrl+arrow up / arrow down to
move tasks. Tasks moves between subprojects – and you cannot move sub projects this
way. However, you can renumber as described below.
Fold/unfold tasks and sub projects
1

Double-click on id of sub project.

2

3

Tasks are hidden.

Doubleclick again to unfold the sub projects (= tasks are now visible).

Double-click on project level folds/unfolds the entire project.
Add a comment
Often you need to save notes, descriptions, questions and other text together with the
tasks. Do this by adding a comment to the task.
Select the cell with the task.
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Click on Comment.
Type additional text in the dialog box.
Shortcut key: In column Taskname use F3. All
other places use ctrl+skift+k.
In the dialog box, you write as much text as you want. A
test indicates that there is room for approx. 15,000
characters, spaced included. This is approx. 4 A4 pages.
You can only write unformatted text. For a new line, use
shift+enter.

Add a comment from other sheet
You can update content in a comment with content from another sheet. On sheets
Comments you find a guide.
Template for comments
The comment is formatted. You can edit the template on sheet Design (sheet might be
hidden).
The comment template is a shape with the name stdComment. Formats are read from
this shape.

First line is used for setting Characters per line (CPL). Used to calculate correct height.

Renumbering of ID's
You can renumber ID’s if you have added or deleted tasks.
Shortcut keys: In sheet Projectplan column Id use F3. All other places – sheets,
workbooks - use ctrl+shift+d.
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Alternative 1: Select heading in column ID. Renumber with F3. All
projects, subprojects and tasks are renumbered.

Alternative 2: Select ID for at project. Renumber with F3.
Subprojects and tasks, belonging to the project, are renumbered. The
hidden values for max task number is reset.
Alternative 3: Select ID for a subproject. Re-number with F3.
Subproject with tasks are renumbered.

Alternative 4: Select cells with content to be renumbered. Value of
first cell is assumed a number.
Renumber with F3 (only in column ID) or Ctrl+shift+d (on all sheets in
all workbooks).

2.4 Scheduling
Two Gantt charts
From version 012, you have the option of working with a double Gantt chart. Your specific
template may not support this feature.
Choose among:

•
•
•

Gantt chart 1: Days are used as units
Gantt chart 2: Weeks are used as units
Hide Gantt: No Gantt chart is visible
Gantt start: Above column Startdate is the start date of the
Gantt chart. You can input any date here or in the Select view
dialog.

Shortcut keys ctrl+arrow-right and ctrl+arrow-left scrolls the Gantt chart a week
forward or back.

Schedule tasks 1 (Early start)
You can also plan with Late Start. Please see next section 'Schedule tasks 2.
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English formula: =MAX(N29+O29-1,N29)
Scheduling is always done by specifying a start date and duration in days. End date is
automatically calculated and Gantt charts are updated automatically. This applies whether
the units in the Gantt chart are days or weeks, and whether you use calendar days or
workdays for scheduling.
Manual scheduling
In the Start Date column, you enter a date in format dd-mm-yyyy. If the date is this
year, you just enter dd-mm. Year is automatically added.
In column Duration, enter duration in days. Depending on your settings, end date is
calculated as calendar- or working days.
Button 'Draw Gantt'
The easiest way to work with scheduling is using F3 or button Draw Gantt. Do this:
1

In the Gantt chart, you select the relevant days. You can use the mouse or
keyboard. Use F3 or click button Draw Gantt.

2

The Gantt bars updates automatically.
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Input end date
All end dates are calculated and you should not input end date as you do with start date
and duration. If the task ends far out in the future, it can be nice to be able to input end
date and have duration calculated.
1

Select Enddate or Duration.

2

Click button Draw Gantt or use
shortcut F3. A dialog opens:
Input end date or start date. Duration
is fixed and the other date is
calculated.

Move task dates
If a task has to start later or earlier you can do it for one or more tasks with button Move
start dates.
1

Select one or more tasks in the Gantt chart.
2

Click button Move task dates (or ctrl+shift+f). Input number of days or
weeks to shift the start dates. Ex.:

•
•
•
•

3: Start 3 days later
-5: Start 5 days earlier
2w: Start 2 weeks later
-3w: Start 3 weeks earlier
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Linked tasks
A task can link to other task by using simple formulas.
Example: In a bathroom renovation project the first sub-project is demolition. First task is
stripping the room of plumbing and fixtures. Then, knock down tiles and scrape the floor.
Finally, the old pipes are removed. Task 2 and 3 cannot start before the previous is
completed.
F3: Link 2 task. Select a start date. F3 links the task with the task above.

If the task already is linked, the tasks are unlinked.
You can do this manually with a formula like Start date = End date of previous task +
1. It may look like this:

If multiple tasks must be linked to the previous one, just copy the formula down.
OBS: If start date is calculated, the date is show in italic – the format is set on sheet
Design.
Scheduling with workdays
Calendar days are used as unit in most project templates. Maybe your template is using
workdays. You work in exactly the same way as with calendar days. The difference is the
length of the Gantt bars.
Here is the formulas used to calculate end date:
Calendar days : =MAX(N11+O11—1,N11)
Working days : =WORKDAY(N11,O11)-1
N: Start date, O: Duration)
Workdays with holiday calendar
On sheet Calendar you may maintain a holiday calendar. The holidays are shown in the
Gantt chart and are used if you plan with working days.

Plan tasks 2 (Late Finish)
Many projects have a fixed end- or delivery date. ProjectTools can do the scheduling for
you on each subproject.
Fast track:

 Select end date for a subproject.  Do F3  Set end date.

You schedule one subproject at a time – starting with the last.
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Plan from end date
1 Create tasks (se earlier) with id, taskname, responsible etc. You must set a duration, but
do not set start or end date yet. Select end date of the subproject:

2 Use F3 to show this dialog and input a date in one of the allowed formats:

4 All dates are recalculated so target tour delivery date:

We are planning with workdays:

•

1011 (yellow) has a duration of 2 days. Next task cannot start until the following
Wednesday. Monday and Tuesday are holidays.

•

1012 (green) has a duration of 3 days. Next task cannot start until the following
Monday.

•

1013 (orange) ends 26-05.
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2.5 Gantt bar colors
You decide what the colors stand for. As standard, you have at least 20 colors. They are
numbered 0 – 19. It may look like this:
Blank and 0 (zero) in the
column Typ (Type) gives the
same result. In most
templates, you enter the
color number in column Typ
but there can be a formula.

The colors are maintained
on sheet Design.
To edit colors: Change the
background color in one of
the color cells. Use F3 to
update all colors.
Colors are also updated
when tasks/projects are
added.

Text on Gantt bars

Add text to Gantt bars
1

Select a cell in the row above the Gantt chart (see image).

2

Use F3: Texts are added. Use F3 again: Texts are removed.

Texts are added as floating text boxes. They do not adjust when you change dates. To
update dates: Remove texts, set new dates, set texts again.
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Select text
On sheet Options write your text in
optGanttLineText

Task {zId} {zOpgavenavn}

Write your text. Text in {} will be replaced with values from the project plan. Use column
headings in square brackets linke [columnheading] or use a named range like {zId}.
Examples:
{zId} or {[ID]}

1011

{zStart} or {[Startdato]}

23-06-2016

{zId} {zOpgavenavn}

1011 Task 2

{zOpgavenavn} (start {zStart})

Task 2 (start 23-06-2016)

{[Task]} ({[ID]})

Task 2 (1011)

{zOpgavenavn} ({zId})

Task 2 (1011)

Change text formats
All formats are copied from a textbox on sheet Design. Select the textbox named
gntTextMaster. Use Excels standard tools for change font-family, colors etc.

2.6 Columns Doc and Map
Doc and Map are used for special documentation-related functions.
Doc
When present, F3 creates special Word documents like delivery slip, quality related
documentation etc. If you have the column, you will have specific instructions on how to
use it.
Map
The columns holds links to folders or documents. You create links like this:
If cell content is … … you get this by click and F3
blank

Click: Nothing.
F3: Show Windows Explorer dialog to select a folder. After OK, a
link to the folder is inserted with text Show.

Show

Click: Folder opens in Windows Explorer.
F3: Like with blank: You can change to another folder.

(other text

Click: Nothing.

without a link)

F3: Show Windows Explorer to select a document. After OK, a link
to the document is inserted.
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Click: The document opens in the associated program.

link)

2.7 Other columns
Your actual template can have other column types: Text, text with dropdowns, numbers,
formulas, date, TRUE/FALSE a.o. Most are self-explanatory, so here are some general
remarks.
Text with dropdown
This type is used to select resources, department,
business area etc. from a list.

Most often the lists are maintained on the sheet Lists:

If you need more info about the codes on the list, you use the shortcut F3 (or select in
the menu Project) to show the list info:

Double click on a value to use it.
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Progress 1
Column Progress shows how much work is done. Enter a number between 0 and 100
direct in the cell:

When 100% of the work is done, the task is changes to green background.
Progress 2
As an alternative Progress can show Effort: Used resources compared to planned. This
function is most relevant in a Production plan, but can be added to all project plans. Two
additional columns are needed:
Blue color: Fewer ressources than estimated are used
(Real <= Est). Red color: Too many ressources are
used (Real > Est).
Colors can be configured on sheet Design.

Status
The column is used for quick overview over unsafe and critical tasks:

Enter a number (1, 2 or 3) direct in the cell. After Enter, the traffic light is updated.
Baseline
When scheduling is ready, button Set
Baseline will copy all end dates to column
Baseline. A format is added to Enddate to
show if a task is overdue compared to your
first plan.
Tasks not completed in time is here shown
with red color, but you can set your own
color on sheet Design.
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Views
Your project plan is a large sheet with many rows and columns - perhaps several hundred
of each. When you work with parts of the Project Plan, you can focus by hiding rows and
columns. A view is a subset of the project plan.
Options
Choose one of two actions when changing a view:
Reset=Y: If one or more rows or one or more columns are hidden, the view is reset. You
must use Select view again to show the dialog.
Reset=N: You always get the dialog box. To reset a view you must use the button Reset
view on the dialog.
If no rows or columns are hidden, the dialog is always opened.

3.1 Select view
In the project template, a number of views are defined. Views can only be used on the
project plan sheet.
Click button Select view. If no view is active, you get the dialog. If
a view is active, the view is cancelled.
TIP: Use shortcut ctrl+shift+i.
This is the dialog:
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(If option optResetView = N button Reset is hidden).
To the left is the list with available views. You can edit and create
your own views. See chapter 9.4 Working with views
Double click to use the view.
Set start date here or directly on
the worksheet.

Gantt settings are saved with the view if you click Use.

3.2 Filter tasks
Filtering means: "Display only rows where (one-or-the-other)." E.g., you can set a filter
that shows only a single sub-project or task with AA as responsible. The filter can be set
manually or by using the buttons in the Ribbon.
Recommendation: Use button Filter on/off instead of Excels standard filter on/off.

This button can better find the range that needs to have filter buttons.

TIP: Many buttons can be used in other Excel workbooks. See section 9.6 Use the
functions in your own workbooks.
Filter on/off
Click to show or hide the AutoFilter arrows. If you selected a cell
outside a legal range, you get an error message: The active cell is
not contained in a database range. Click a cell within the range
and try again.

Views
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When the filter arrows are visible, you can manually configure the
filters. You can also proceed with the quick filter buttons.
Quick filter =
Use to set a filter based on an example = content in the selected
cell.
TIP: If a column has a filter, the filter is removed by next click on
Quick filter = or Quick filter <>.
The Quick filter buttons are really useful! Their function may be
different from Excel's built-in filter functions.
The functions works differently depending on what type of field
you use it:
Empty cell
If the cell is empty the filter is set immediately.
Subproject

To filter a single subproject: Select ID of
subproject header. Use Quick filter=.
Dialog opens with active interval predefined.
Just click OK.

Numbers

Columns with numbers are filtered with either a single number or
an interval. If a cell with the number 20 in the ID column is
selected, you can choose to show all tasks with ID = 20. You can
also enter a range like 20 29. This will show all tasks with
ID>=20 and ID<=29.
You can fine-tune the number filter with Excel's built-in filter
options.

Dropdown

If the cell content is selected from a list, the filter is set
immediately.

Text

If the cell contains text, a dialog box appears. The filter finds all
rows where the content of that column is the same as the filter
text. When typing ABC as a filter text, ABC is found but not AABC
or ABCC.
Use * and ? as wildcards. ABC* finds ABC, ABCC, ABCD and
ABCDEF. ABC? finds ABCC and ABCD. ABC* finds ABC and AABC.
Common uses

•

Find all tasks, where AA is project manager (= is written
first). Filter: AA*

•

Find all tasks, where BB is only resource. Filter: BB

Views
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Select one of 5 options for filtering. The dialog box appears if you
select a cell with a date. Here we assume that you selected a cell
in column Start Date:
>> A single date (24-12-2009): Only tasks with the specified
Start date are displayed.
>> An interval (24-12-2009 12-02-2010): Enter two dates
with a space. Only tasks with a start date in the range shown.
>> An interval (+90): Write + / - x days to view the tasks from
the selected date and x days ahead.
>> A specific month (M11): Write MXX to view all tasks with
start date in month xx (whatever year).
>> A specific year (Y2009): Write Yxxxx to view all tasks with
start date in a year xxxx.
Quick filter <>
The function works as Quick Filter =, just the reverse. One use:
Select an empty cell in a column. Click Quick filter <> to hide all
rows with empty cells.

3.3 Sort
Recommendation: Save your project plan before you sort.
Recommendation: It is safe to sub-sort some tasks only if you use the sort function
of Project Tool.

Sort the entire project:

Sorter ascending/descending
1) Select any cell in the column to be sorted.
2) Click button Sort Ascending or Descending.
TIP: Shortcuts for sorting are

•
•
•

Ctrl+2: Standard sort
Ctrl+3: Sort ascending
Ctrl+4: Sort Descending
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Sort a subproject
Before sorting the tasks, you must edit the ID to correct
order. At the left 11, 12, 15, 14, 13 is the desired order.
1) Select the tasks to be sorted. Here we are sorting on ID,
but the tasks 10 and 16 should not be re-sorted.
2) Click Sort Ascending. Since there are selected more than
one cell, you get a dialog box:

Use ’Yes’ to sort.
The tasks are now sorted in correct order.
Note: The normal Excel sort function sorts only selected
cells. Here you are safe: The entire rows of the selected
cells are sorted.

Standard sort
How to use:
1

Try to sort (asc/desc) on different columns. Now you have an unordered project.

2

Click Standard Sort. In one click, everything is back in place.
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Reports
As standard, these reports are included:
1. ToDo: Show a list of tasks. Comments are included as text. Type is Multi, so all visible
tasks are included. Existing content is deleted before update.
2. Archive: Like ToDo, except that existing content is preserved.
3. Reports with timelines:
a.

Month: Show tasks with 24 months.

b. Week: Like Month but showing 53 weeks.
c.

Day: Like Month but showing 30 workdays.

d.

Q: Like Month but showing 20 Quarters = 5 years.

4. OC: Order confirmation. Merge standard text with data from single task.
In your specific solution, you can have more or fewer reports and the naming and size
can be different.

4.1 Update a report
Update Single (OC)
Update
1

Select report. Select an ID: Input an Id or Select input cell and use F3 to
get a list with Id and Taskname
Update with F3 or button Report.

Update Multi (Month, Week, Day, Q)
Update
1

Sheet ProjectPlan: Select data for the report. Use a view or Quick Filter or
filter manually.

2

Select the desired report sheet. Use F3 or button Report to update.

4.2 Report settings
When you get your project template, everything is ready to use.
Sheet Options
The curious users can go to sheet Options and view the comments in the report section.
Report type Single: If you have it, you got further instructions to edit and use.
Report type Multi: If you have it, you got further instructions to edit and use. To create
your own you need a short workshop.

Communicate your Project Plan
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Communicate your Project Plan
The Project Plan is used by the project manager for planning and monitoring. During a
project, there are many situations where the project manager must communicate the
entire plan or parts of the plan. There are several ways to do it: Print, send a pdf, send
sample as Excel file, send the contents in email or send the entire plan as attachment.
No matter what, you always start by selecting a view. When you have done that, you can
continue reading.

5.1 Reports
All reports are ready to print and/or send as email.

5.2 Print
Click Preview (or Office menu > Print > Print Preview). If everything is beautiful, click
Print.
To print out both project plan and ToDo list, start by selecting two sheets: Click on the
sheet Projectplan, ctrl + click on the sheet ToDo. Do a Print preview > Print. REMEMBER
to cancel selection of multiple sheets! (Click on a sheet outside the selection).

5.3 Send sheet as e-mail
Works only with one of these e-mail clients:

•
•

Microsoft Outlook in same version as Excel
IBM Notes (former Lotus Notes)

You can send all sheets in all Excel files as content in e-mail. Activate the sheet and click
Create e-mail.
An html-email is created, ready to add recipients.
Get your own sheet ready to send
All sheets can be sent as content in an email if it
has a print area. Cell outside the print area is not
included. First cell above the print area (if any) is
used as subject line in the email.
In this report, the print area is selected. First line
above holds the text for the subject line. Here the
text is the result of a formula.
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5.4 Send Email, Appointment or Task
As responsible for a task in the project plan, it is useful to create the task in Outlook
together with all your other tasks – and maybe put it in your calendar. You can create a
task, an appointment or an email from the tasks in the project plan.
More than one responsible: A task can have more than one responsible /
resource. If initials are separated by a space, an Outlook element is created for each.
If a resource is not on the contact list, the item will just be created without a
recipient.

Create Outlook item
1 Outlook item will be created for the selected row. In our examples we use these
tasks:
Project plan as of 16. september 2011
My little project
ID OBS
54
55

Task
A very important task
Another task

Resp
OLE
ANN

Progress

Gantt start
15-09-11

End
01-01-99

Start date
15-08-11
01-09-11

Dg End date
45 28-09-11
30 30-09-11

Observe that OBS is yellow for one task, and progress is 40% and 80%. On sheet,
Contacts OLE and ANN are completed with initials, name and a valid email-address.
2 Go to the menu Project > Outlook….
3

Select one of the three
elements and adjust the
settings.
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Create e-mail
1

Select one of the defaults for
email Subject – or write
your own.

Use these variables to insert info about the active task:
<TASKID> ID
<TASK> Task name
<DUEDATE> End date
The default subjects are picked up from sheet Lists. You can edit the list. If
the list is not available, you can create your own by name the range
listMailSubject.
2

Your email is
created with you as
sender and the
responsible as
receiver.
Your subject is
inserted and the
comment on the
active task is used
as content in the
email. The email is
not sent. You have
to click the Send-button to send it. If you do not send the email, it is saved
in your Outlook Drafts folder.

Communicate your Project Plan
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Create an appointment
1

When you create an appointment,
you can choose a location.

2

The invitation is created with you as facilitator and the responsible for the task as
participant. Subject, location, text in comment and date are all picked from the task
in your project plan. Observe that the meeting is by default held from 9 to 10.
You send the invitation manually.

Communicate your Project Plan
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Create task
1

When you create an Outlook task, you can
choose to set a reminder.

2

Please observe that

•

the task is assigned to a responsible. If it is your own task, you just delete the
recipient. Click Save and close instead of Send.

•

Subject, content, start date, end date, priority and progress (80%) is picked up
from the task in your project plan. If the status is yellow or red, the priority on
the Outlook task is set to High.

•

The (Outlook) Status is different from Status in the project plan. Status in
Outlook is always set to In progress, and Outlook Priority is set to normal if
project plan status is green.

3

The responsible can se the reminder, which is set to 3 days before due date.
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5.5 Create ToDo/Task (IBM Notes)
Contact me for further instructions.

5.6 Take a picture of your plan
Example: In your PowerPoint presentation, you would like to show the project plan with
Gantt chart. The easy way: Select a view and take a picture. Go to PowerPoint and paste
the picture with ctrl+v. It is easy, quick and lightweight.
1

IF a range of cells are selected: Your picture shows the selection.
IF a single cell on the project plan is selected: Your picture shows the entire
project plan.

2

Go to menu Project > Take picture.

Paste the picture everywhere with ctrl+v. If a view is active: Note that the filter arrows
are not in the picture.

5.7 Export sheet
Any sheet can be exported with Project > Export sheet. This is what happens:
1. A new destination sheet is inserted.
2. All visible content and formats from your source sheet is inserted as values.
3. The sheets is exported to a new workbook. All names and external references are
deleted. No hidden properties are left.
4. Optional: The sheets is saved as saveFileName in saveFolderName.
The exported sheet is complete safe to send. No formulas, no hidden cells, no hidden
properties.
Options
On sheet Options you can set a name and folder for the file to export.

If filename or folder name is empty, you are prompted for a name.

5.8 Send project plan
Send as PDF
Select one or more sheets. Select Office Button > Save As > PDF or XPS. You have now
created a PDF file with continuous page numbering.

Consolidated project plan
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Consolidated project plan
Data from several project plans can be consolidated in a common project plan. Example:
In Placebo Inc. each department A, B and C maintains project plans A, B and C. Each
week the company’s master project plan is updated and used in a planning meeting.
The update is performed in two steps: 1) Each project manager exports report data to a
common report folder. 2) The Project Report imports the data.

6.1 Settings
Report
The report and report data are saved in a shared report folder. In this example, it is
F:\Report. After the folder is created, open the report (xlEasy_ProjectReport.xlsb) and fill
xmlOpenPath with folder path on sheet Options:

Project plan
When data are exported from a project plan, they are saved in a folder with a file name.
The folder must be the same as above (F:\Report). File names must be unique for each
project plan. In this example, we use A-data.xml, B-data.xml and C-data.xml.
Department A’s project plan is configured like this:

Repeat for project plan C and B.

Consolidation
In this example each project manager opens the project plan, adjust the view and clicks
button Export data. Only visible cells are exported.
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Folder F:\Report now contains 3 xml-files (A-data.xml, B-data.xml and C-data.xml).
Open the report file and click Update report. All xml-files in the folder is now imported.
The report is like any other project plan so you can use views, create ToDo lists etc.
OBS: All data in the report file can be edited including the Gantt chart etc.
Remember that all changes are lost after next update. Only changes in the individual
project plans are preserved.

7

Production plan
Your Production Plan is ready to use. Everything in the Production Plan is like the Project
Plan. Some extra features are self-explanatory or documented in the plan.

8

Workplan
The Workplan (Arbejdsplan) is only distributed in Danish.
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Technical info

9.1 Help
All help info is found in this manual. It is distributed in pdf-format with bookmarks, so it is
easy to navigate on screen. You can of course print to read in bed.
If you need a new copy, you can download a new. Go to menu Project > Help.

In the dialog, you find a link to this manual.

9.2 Security settings
With standard security settings in Excel 2007/2010/2013/2016, you have to accept
macros each time you open ProjectTools or your project plan. You can change the settings
to always accept these files.

”Trusted locations”
As part of the security in Microsoft Office, folders can be promoted to be a safe launch
pad for your files. Read more about Office 2007 or Office 2010/2013.
A Trusted location is added in the security center. In this example, the project plan is
located on a network drive and ProjectTools is located on the local drive.
Network drives
If your project plan is saved in folder H:\department\projects\ you need to add the folder
to your collection of Trusted locations.
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Go to Office button > Excel options.
(The screen dumps here are from a
Danish Office install but the buttons
are in the same position in other
languages )

2

Click Trust Center > Trust Center Settings.
3

Go to Trusted locations.

4

Select Allow trusted locations on my network (not recommended). Click Add new
location.
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5

Click Browse… to find your folder. Select Subfolders of this location are also trusted
check box.
6 Click OK and OK close security center.
This has to be done only once – but for each user.

9.3 Installation
You need a project template and your ProjectTools to manage your project. The project
template is a normal Excel workbook so you can save it anywhere.
ProjectTools is an Excel macro enabled addin (*.xlam). There are two ways to ‘install’ the
addin. Choose between manual start and automatic start.

Auto-installation
First time you open the addin the auto-"installer" runs. Restart Excel to check the addin is
loaded.

Manual start
If you only use ProjectTools a few times a month you might prefer to open ProjectTools
only when you are working with the project template. Then you just save the *.xlam file
in a folder of your choice. To open the addin: Find it and double click.

Automatic start
If you use ProjectTools often or if you like to use the general functions in other
workbooks, you should register the addin.
Technical info about auto-install:
1. If folder (documents)/xlEasy does not exist it is created.
2. File NNN_ProjectTools_YMM-en.xlam is copied to
xlEasy/NNNProjectTools.xlam
3. NNNProjectTools.xlam opens and is registered as addin.
If you later need to "un"-install do one of the following:
1. Go to Project > Install, select 2 Uninstall. When Excel restarts, it does not load the
addin.
2. Delete the file.
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Auto-install does not run if the file opens from af path with xleasy in it. If saved in
projectdocuments/xleasy-files/projects auto-install is bypassed.
Add a shortcut to Excels start-up folder
1

Go to group Project > menu
Project > Install…

2

Input 1 and click OK.
ProjectTools now always starts
with Excel.

3

To disable auto start: Go to same menu and select 2.

Option 3: Add a shortcut to Windows Favorites. Now it is easy to start ProjectTools
manually.
Option 4: Add a shortcut to the active Excel file. Use it if your project plan lives in a
remote network drive. Now you just have to find your project plan in your favorites in the
Windows start menu.
Option 5: Windows Explorer starts in your Favorites folder for cleanup and rearranging.

9.4 Working with views
You can add, edit and delete views. Views are hidden in the system range above the
project plan.
Edit a view
1 To unhide system area click a cell in first visible row on sheet. Using F3 will unhide.
2
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Views are named Planning, Next week etc. You can use them as they are or you can
rename, edit and delete the views. You need to have at least 2 views.
The first 3 columns are special:
Edit the name: Just write another name in the cell.

•
•

Gantt: Here you save settings for the Gantt charts. 2-08 means: Use Gantt
chart 2 (weeks). Show 8 weeks. You can edit the cells directly. Your content is
overwritten if you click Use in the dialog.
Weekend: 1 = Show weekends. 2 = Hide weekends. Only relevant for Gantt

•

chart with days.
All other columns are working like this:
Select columns. To display a column in a view: Mark the column with x

•

(lowercase letter x). To hide a column in the view: Blank or any other character
but x.
Filter. After the first character, you type a filter condition to be applied to rows

•

in that column. Below are a many interesting examples.
Macro based filter: .=1|vbaU2 runs macro vbaU2 before filter is set with

•

(=1). See examples below.

Filter examples
You can use filters with one or two conditions. Set filter manual, by formula or by macro.
In the examples first character is either x (column is visible in the view) or something
else ( . i.e. a dot = hide column in view). Filters can be active on hidden columns.
Filters with 1 condition:

•
•

x>=100 (in ID) means: Show all rows with ID greater or equal 100.
x<> (in Task name): Display the column in this view (the ’x’). Use filter
(<>) not equal (nothing), that is: Hide row if cell is empty. Use as
standard in column task name.

•

=NNN: Use this filter in column Responsible to get a list where NNN is
responsible and the only resource.

•

=NN*: Use filter to get a list where NN is responsible w/wo other
resources.

•

=*NN: Use filter to a list where NNN is a resource (but not
responsible).

•

=*NN*: Use filter to get a list of task where NNN is involved, no matter
if it is as only resource, participating resource and responsible.

•

<>*NN*: Use filter to get a list of tasks where NNN is not involved in
any way.

•

.=1: Hide this column (first character is not x), but apply filter equal to
1. Use in columns with priorities, phases, departments etc.

•

x=100 in column Progress: Show only completed tasks, i.e. equal
100%
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x>1 in column Status: Show only tasks with status greater than 1, i.e.
tasks flagged as yellow or red.

•

x>31-01-2016 in column Start date: Show only tasks starting after
January 2016.

Filters with two conditions:
Do as with one condition. To add a second condition use operators &
(= AND) or / (= OR). A space is need on both sides of the operator.

•

x>=100 & <1000 in column ID: Show rows with ID between 100 and
999.

•

x=AA / =BB in column Responsible: Show rows where AA OR BB are
(single) responsible.

•
•

x=AA / =AA*: Show rows where AA is either resource or responsible.
x>10 & <50 in a column with numbers: Show rows with value between
10 and 50.

•

x>1 & <100 in column Progress: Show active tasks, i.e. not 0 (not
started) or 100 (completed).

Filters with formulas:
You can create formulas to get dynamics filters. Example: Show all tasks
where start date is later than today.1

•

="x>"&TODAY() in column Start date: Formula is shown as
x>40277, (date value April 9th 2010). It says: Show only rows with
start date later than April 9th 2010.

Here is a last dynamic filter:
"x>"&INT(AVERAGE(INDIRECT(K9))) i a column with numeric values.
Formula is shown as x>11 – which is easy to understand. 11 is the
interesting part: It's the average of all tasks. The filter shows at all time
tasks above average.2
Filters with macros:
Why?
In your view you need to show 1) tasks where something is happening
within next two weeks and 2) the projects they belong to 3) except when
TYPE = EXT and 4) ...

1

In some templates the filter range is formatted as text. If you need to use a formula, you must change the format
to Standard.
2
INDIRECT(K9): In cell K9 is a formula with the address of the range to be calculated. It says somthing like
K13:K54 which is a range of all data cells in the project plan in column K. The formula in cell K9 is like this:
=ADDRESS(ROW(dbPlan)+1;COLUMN(K9);4)&":"&ADDRESS(ROW(dbPlan)+ROWS(dbPlan)-1;COLUMN(K9);4)
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When filtering gets complicated, we use a macro to set a value (normally 1)
for all rows to include in the view.
How?
Two hidden columns are included for filtering. You can add more if needed.
Example: . =1|vbaU2 runs macro vbaU2 before filter is set to (=1). The
pipe character (|) separate the filter from the macro name.
Use your own macro name. The macro must be saved in the active
workbook. Write as many you need – or call the author for help.
If .=1|vbaXYZ refers to a macro (vbaXYZ) that does not exist, no filter
values are set but the filter (=1) is set anyway. All rows are hidden.

Available advanced filters
The filters are included:

•

vbaInit (use like : . =1|vbaInit=*BE*). Show all tasks where BE is
responsible and their parents (project + subprojects).

•
•
•

vbaU0 (use : . =1|vbaU0). Show all tasks with action this week.
vbaU1 (use : . =1|vbaU1). Show all tasks with action next week.
vbaU2 (use : . =1|vbaU2). Show all tasks with action the next two
weeks.

•

vbaU4 (use : . =1|vbaU4). Show all tasks with action the next four
weeks.

•

vbaProj1 (use : . =1|vbaProj1=*text*). Show all Projects with text
in the name. Subprojects and task are included.

•

vbaProj2 (use : . =1|vbaProj2=*text*). Show all Subprojects with
text in the name. Tasks and parent (project) are included.

Advanced sorting

•

vbaSort: Creates a sorting index in column [Filter]. It is used with a
report like Day. On the report is set a standard sorting. When report is
updated, all tasks are sorted end date ascending: You have a waterfall
report.

Add a view
Add a view by copying and editing an existing view:
1

Unhide the system range.

2

Insert an empty row:
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Select a row. Insert an empty row with ctrl + plus.
Copy from above with ctrl + d.
NOTE: You can insert a new row between any of the existing rows – but you
cannot insert a new row before the first row.
3

You now have two identical views. Edit one as described earlier.

Delete a view
Delete a view by deleting the entire row:
1

Unhide system ranges (F3 in first visible row).

2

Select the entire row by right clicking on the row number:

Delete with ctrl + minus.

See a list of nice shortcuts in section 9.7 Shortcuts.

9.5 Customize design
The visual elements are controlled by two Excel-concepts: Styles and conditional
formatting.
Styles
Each column in the project plan uses 3 sets of styles for projects, subprojects and tasks.
On the Home tab in the ribbon, all styles are available. It could look like this:
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The style for the selected cell is subtext. If you would like to change the background color
of subprojects, you need to change background color in all sub* styles.
Conditional formats
The Gantt chart and some of the other columns uses conditional formatting. The colors
and formats are customized on sheet Design. Read the comments on the sheet to get
more info. Look for the question marks:
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After editing, the formats are activated with F3: All conditional formats are deleted and
new are created.
So: Do not bother to create your own conditional formats – they will soon be deleted.

9.6 Use the functions in your own workbooks
All Data functions and some Project functions can be used in other workbooks.

Data functions
The Data functions need special naming of the ranges you work with. They work well
when used on ranges with these names:

•

Database is a well-known Excel name. Excel recognizes it and uses it in pivot tables,
advanced filtering etc.

•

Name begins with db (short for database like dbPlan, dbReport, dbBudget, dbContacts
etc.). These names should only be used for standard data ranges.

•

Name begins with tb (short for table like tbPlan, tbReport, tbBudget, tbContacts etc.).
These names should only be used for Excel Tables (former knows as Lists).

When using these names the range must have this structure: First row is used for field
names (headers, labels). All the other rows are data rows.

Project functions
These project functions can be used in all sheets:

•
•
•
•

Comment
Copy as text
Copy sheet (only visible cells)
Move selected sheet to new file

Copy as text
Select a range. Copy as text puts an unformatted copy in the clipboard. The text can now
be inserted in other programs (Outlook, Word etc.) with Ctrl+v.
Copy sheet
This function creates a copy of the active sheet, but in the copy, you only have visible
cells. All hidden rows and columns are left behind. All formulas are converted to values.
Objects (shapes, charts etc.) in the sheet are also copied.
Move selected sheets to new file
Select one or more sheets and use Move.... The sheets are moved.
NOTE: As a safeguard against mistakes sheet name must begin with Exp (for Export), for
example ExpProjectplan. When using the copy function sheets are automatically named
this way.
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9.7 Shortcuts
Multi shortcut key F3
Use F3 in your project plan. Its function depends on the column:
Column

Function

ID

Renumber

ID heading

Renumber entire ProjectPlan

Taskname

Comment (alternative to ctrl+shift+k)

Resp

Show list info

Other columns with a list

Show list info

Doc

Create document with info from task/project

Map

Insert link to folder or document

Startdate

Link task with task above

Enddate (task)

Enddate dialog

Enddate (subproject)

Schedule (Late Start) the subproject

Gantt chart

Draw Gantt line (alternative to ctrl+shift+g)

Gantt chart (heading)

Add or remove text to Gantt bars

Multi shortcut F3 on other sheets
Column

Function

Reports

Update report

Design

All formats are updated

Comments

If active cell is id-selector: Show list with tasks.
Else: Create a comment from selections.

Data functions
Ctrl+2

Standard sort

Ctrl+3

Sort ascending

Ctrl+4

Sort descending

Ctrl+arrowup/down Move a task in the project structure.

Project functions
Ctrl + arrow
right/left

Scroll the Gantt chart a week forward or backwards.

Technical info
Section 9.8 History
Page 42 / 43

Ctrl+skift+k

xlEasy ProjectTools

Comment (Kommentar): Add/edit comment. Use multikey F3 in
column Taskname.

Ctrl+ Shift +L

FiLter on/off (we just use the standard Excel shortcut to our own
purposes)

Ctrl+ Shift +I

Select view / cancel view

Ctrl+ Shift +F

Move (Flyt) dates.

Ctrl+Shift+D

Renumber: Fill cells

Down width series, starting from the number

in first cell. Use F3 in column Id.
Ctrl+Plus

Add a new task. Select multiple rows to insert multiple tasks.

Ctrl+Plus in ID

Show the dialogue Add... to add projects, subprojects and tasks.

Ctrl+Minus

Delete one or more rows.

Standard Excel shortcuts
F2

Edit cell. Navigate with Home, End, arrow-keys, Ctrl+Home/End
etc. Finish editing with Enter, TAB, arrow-key etc.

Shift+F2

Insert/edit comment. ESC moves selection from text to border.
Here the comment can be deleted with Delete. One more ESC hides
the comment.

Rows
Shift+space

Select entire (table-)row. If selection is in a table only table row is
selected.

Ctrl+Plus

Insert cells. When entire (table-)row is selected: Insert entire
(table-)row.

Ctrl+Minus

Delete cells. When entire (table-)row is selected: Delete entire
(table-)row.

Columns
Ctrl+space

Select entire column.

Ctrl+Plus

Insert cells. When entire column is selected: Insert entire column.

Ctrl+Minus

Delete cells. When entire column is selected: Delete entire column.

9.8 History
News in version 606

•

New: Insert/Delete tasks, subproject and projects with shortcuts Ctrl+Plus and
Ctrl+Minus.
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New: Advanced filtering in Views. Select projects/subprojects based on name
pattern: Select all subprojects named "*development*".

•
•

New: Automatic installation/upgrade when a new ProjectTools is opened.
UPD: Timeline color dependent on responsible is now standard.

News in version 510

•

New: Schedule a sub project from delivery date (ALAP = As Late As Possible or Late
Start). Input just end date and have all tasks scheduled from that.

•
•

New: New advanced features when filtering views. Fast, lightweight and code-based.
New: e-conomic integration is re-written to overcome limitations in datasets. Tested
with 25.000+ records.

•

New: In Consolidation an extra header can be inserted before each subset, making is
easier to navigate in large consolidated plans.

•

Fixed: Input end date and keep duration. Text on Gantt lines.

Earlier versions
Earlier versions are 505, 410, 406, 403, 402, 401, 312, 302, 210, 207, 112, 109, 107,
102, 012, 006, 004, 002, 001 and 912.

